small bug in "convtoflac" ?

Note: The following message was originally posted by an unknown forum member on 05/30/2010, but was flagged as spam. I'm manually reposting it here to make it available to everyone.

Hello there,

just used your script to to some .ape -> .flac conversion.
I used the -f flag since the other didn't work and I encountered the following issue, log:

convtoflac "Vol. 1/Various - The Best Of Italo Disco vol.I (LP).ape" -f

Processing 'Vol. 1/Various - The Best Of Italo Disco vol.I (LP).ape'...

FFmpeg version SVN-r23328, Copyright (c) 2000-2010 the FFmpeg developers
built on May 25 2010 23:10:05 with gcc 4.5.0 20100520 (prerelease)
configuration: --prefix=/usr --enable-gpl --enable-libmp3lame --enable-libvorbis --enable-libfaac --enable-libfaad --enable-libxvid --enable-libx264 --enable-libtheora --enable-postproc --enable-shared --enable-pthreads --enable-x11grab --enable-libopencore_amrnb --enable-libopencore_amrwb --enable-libschroedinger --enable-version3 --enable-nonfree --enable-runtime-cpudetect
libavutil 50.16. 0 / 50.16. 0
libavcodec 52.69. 0 / 52.69. 0
libavformat 52.65. 0 / 52.65. 0
libavdevice 52. 2. 0 / 52. 2. 0
libavfilter 1.20. 0 / 1.20. 0
libswscale 0.10. 0 / 0.10. 0
libpostproc 51. 2. 0 / 51. 2. 0
Input #0, ape, from 'Vol. 1/Various - The Best Of Italo Disco vol.I (LP).ape':
Duration: 01:18:28.31, start: 0.000000, bitrate: 837 kb/s
Stream #0.0: Audio: ape, 44100 Hz, stereo, s16
/tmp/Vol. 1/Various - The Best Of Italo Disco vol.I (LP).wav: No such file or directory

Error: "Vol. 1/Various - The Best Of Italo Disco vol.I (LP).ape" could not be converted to a FLAC file.
rm: Entfernen von „/tmp/Vol. 1/Various - The Best Of Italo Disco vol.I (LP).wav“ nicht möglich: Datei oder Verzeichnis nicht gefunden

Can it be that $PWD has to be where the actual file is or otherwise it will not work ?
Script tries to access /tmp// which does not exist : (

The file is apparently in a sub folder "Vol. 1"

Would be neat not have to go into each subfolder to do the thing we want. Hope I didn't mix something up, since it works as soon as
I go into the files folder to do conversion.

Bye

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jbreland's picture

Re: small bug in "convtoflac" ?

Hi, thanks for the report. Offhand, I'm not sure what could cause this. Convert to FLAC should support converting files on other directories, but I've only done casual testing of that, so it's hard for me to say for certain.

Wait, just read a bit further: when you say that "Script tries to access /tmp// which does not exist," do you mean that the file specified doesn't exist, or that /tmp itself doesn't exist? If /tmp doesn't exist, then that'll definitely cause it to fail as ffmpeg must write out the full wave file to /tmp before flac can encode it. If you mean the former, then I'll need to investigate when ffmpeg is not writing that file out properly.

I'll do some testing when I get a chance (should be in the next couple days or so) and see if I can reproduce the issue. Will let you know.

jbreland's picture

Re: small bug in "convtoflac" ?

I've confirmed the problem. This will occur when using ffmpeg to transcode a file that is not in the current working directory. A bit more detail can be found in the bug report I created for this.

This will be fixed in the next release, which should be out soon (probably tonight, unless I run into any problems).